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TaiRox Mail Merge 

TaiRox Mail Merge integrates Sage 300 with Microsoft Word’s mail merge function. The integration 

presents a Sage 300 style interface from within the Sage 300 desktop.  

Mail Merge is designed for the production of merge documents from Sage 300, and is integrated with A/P 

vendors, A/R customers, I/C items and US and Canadian Payroll employees. It eliminates the need to 
export data from Sage 300, manually manipulate that data, and define the resulting file as a Microsoft 
Word “data source”. 

All A/R, A/P, I/C, and PR merge data fields are displayed with field definitions to make it easy to prepare a 

“mail merge template” within Microsoft Word. Optional fields can also be added to mail merge documents. 

Once you have created mail merge documents, you can select vendors, customers, items or employees 

using exactly the same mechanism used to select records in reports. After selecting ranges of data, you 
can “cherry-pick” the results for the mail merge.  

Mail Merge lets you: 

• Perform the mail merge operation from the Sage 300 desktop. 

• Select a number of print options for the merge documents, such as data formatting and blank line 
suppression. 

• Select ranges of vendors, customers, items or employees using ranges of up to seven fields. 

TaiRox Mail Merge selects ranges with the same mechanisms used by core modules when 

printing reports. 

• Specify the vendors, customers, items or employees by importing an Excel spreadsheet list. 

• Specify additional criteria for record selection. 

• “Cherry-pick” records for generating merge documents from the selected set of vendors, 
customers, items, or employees.  

• Click the Mail Merge button to complete the document merge operation for all included records in 
one step.  

• View a log of all document merges after processing. 

Running Mail Merge 

The Mail Merge icon appears in four locations under TaiRox Productivity Tools – in the Accounts 

Payable, Accounts Receivable, Inventory Control, and Payroll Tools folders on the Sage 300 desktop. 

        
Note that Enterprise Productivity Tools appear only if you have an Enterprise license from TaiRox Software. 
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Select the appropriate Mail Merge icon from the Sage desktop to create merge documents using a 
selection of vendors, customers, inventory items or employees. 

Choose the merge document template and output document for the merge 

Users must first select a mail merge template (MS Word document) and an output document. 

 

If you are sending letters to all vendors (for example), you can click the load button and then click the Mail 
Merge button to create merge documents in the “Document” file. 

• Note that the program date choice (in the above screen, Accounts Payable) depends on the 
which Mail Merge icon you choose.   

Selecting vendors, customers, inventory items or employees 

Choose data ranges for creating merge documents: 

 

• You can use up to seven fields to specify ranges of vendors, customers, inventory items, or 
employees for the merge. 

o Vendors – vendor number, status, start date (to send to new vendors), group code, account 
set, currency code, terms – or any of the optional fields used for vendor records (as shown in 
the dropdown above). 

o Customers – customer number, status, on hold, account type, national account, group code, 
start date (to send to new customers), account set, currency code, billing cycle, terms, 
territory code, salesperson1 – or any of the optional fields used for customer records (as 
shown in the dropdown above). 
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o items – by item number, item category, or account set – or any of the optional fields used for 
item records.  

o Canadian Payroll employees – by employee list, employee number, employment status, 
birth date, hire date, termination date, position, part-time, pay frequency, cheque language, 
workers compensation code, overtime schedule, shift differential schedule, supervisor, last 
review date, date of last raise, or work classification code.  

o US Payroll employees – by employee list, employee number, employment status, birth date, 
hire date, termination date, position, part-time, pay frequency, check language, workers 
compensation code, overtime schedule, shift differential schedule, supervisor, last review 
date, date of last raise, or work classification code.  

For instructions on importing a list of mail merge recipients using the File > Import menu choice, see 
Importing a List of Mail Merge Recipients. 

Choose additional criteria: 

 

• Click Additional Criteria to further restrict the records retrieved for the mail merge. In this case, we 
are only going to use vendors in BC. 

• Click OK to save. 

Load the list of selected records and choose which ones to use: 

• Click the Load button to display the selected list of records. 

 

o Go back and adjust the ranges or additional criteria if necessary. 

Importing a List of Mail Merge Recipients 

Important: If you are importing a mail merge recipient list, you must first select a mail merge template 
(MS Word document) and an output document. See Choose a merge template and output document. 

• Choose File > Import from the Mail Merge menu. 

 



TaiRox Mail Merge Choosing Recipients from the Grid 

TaiRox Productivity Tools for Sage 300  4 

© TaiRox Software Inc. All rights reserved.  

• Select the list of mail merge recipients that you want to process. 

 

Note that you the list type will depend on which version you Mail Merge you are running – for 

example, you will import a list of customer numbers if you run Mail Merge from the Accounts 
Receivable Productivity Tools folder. 

• The program will import the list and load all relevant recipients into the grid – setting all recipients 
to “Include” – and display a message stating the number of recipients that were successfully 
loaded, and the number of recipients that could not be imported. 

 

All valid records will be loaded into the grid at the bottom of the screen. You can then confirm which 
items you want to merge. 

In the above screen, one of the customer numbers was invalid, so the program could not import a 
record. 

Choosing Recipients from the Grid 

• Use the Select All and Select None buttons below the grid to set all records to Yes for Include or 
No to exclude. 

 

• Double-click in the Include column to “cherry-pick” from the records: 

 

• Click the Vendor Number or Customer Number column in A/P or A/R Mail Merge heading to drill 
down on the selected record to confirm the details: 

 

Click the Mail Merge button to run the mail merge: 

Click the Mail Merge button at the bottom of the screen. If the target document does not exist, the 
program will display a message and create the document for you when you proceed. 
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When the merge operation is complete, the program asks if you want to open Microsoft word to print 
the merge document. 

  

Additional Mail Merge settings 

To display additional settings for mail merges, select File > Settings from the Mail Merge menu. 

 

The settings form appears as follows: 

 

Format Field Values: This setting determines whether or not to use the field presentation information 
defined for the Sage 300 field, or whether to use the raw data value.  

For example, field ARCUS_SWACT (Customer Status) has 2 presentation values, Inactive, and Active, 
which represent the raw integer values of 0 and 1 respectively.  

If you select this setting, the program will insert a merge value of “Inactive” for inactive customers; if you 
do not select it, the program will insert a “0” into your document. 

Perform Mail Merge with Word Maximized: This setting determines whether Microsoft Word is run in 
the background or it is launched in the foreground (letting you view the mail merge operation). 

Highlight Merge Fields: You can use this setting to help proof your merged documents. 

Suppress Blank Lines: By default, Microsoft Word suppresses blank lines in a mail merge when the 

result of a MERGEFIELD is blank. However, when you perform a conditional mail merge, the result of a 
conditional field may be blank – which will cause an extra blank line. You can use this setting to 
determine whether to suppress blank lines or not. 

Pause Mail Merge on Error: You can use this setting to pause the mail merge process and display a 

troubleshooting error should you encounter problems while running the mail merge. 
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Creating Merge Templates for Mail Merges 

Sample mail merge templates in \Sage300\XLxxx\Documentation 

TaiRox Productivity Tools includes the following sample mail merge documents for A/P, A/R, I/C, US 
Payroll and Canadian Payroll which contain commonly used merge fields. The I/C sample is an item 
label. You can use these documents as a starting point for creating your own templates. 

AP.Doc: Includes the following fields -- «APVEN_VENDORID», «APVEN_VENDNAME», 
«APVEN_AMTBALDUET», «APVEN_SWACTV», and «APVENO_VENDORCLASS». 

AR.Doc: Includes the following fields -- «ARCUS_IDCUST», «ARCUS_NAMECUST», 
«ARCUS_AMTLASTSTT», «ARCUS_SWACTV», and «ARCUSO_UPSZONE». 

CP.Doc: Includes the following fields -- «CPEMPL_EMPLOYEE», «CPEMPL_FULLNAME», 
«CPEMPL_MINWAGE», and «CPEMPL_STATUS». 

IC.Doc: Includes the following fields and also shows you how to create a label page with multiple labels –  
«ICITEM_FMTITEMNO» and «ICITEM_DESC». 

UP.Doc: Includes the following fields -- «UPEMPL_EMPLOYEE», «UPEMPL_FULLNAME», 
«UPEMPL_MINWAGE», and «UPEMPL_STATUS». 

Displaying available merge fields 

To view a list of mail merge fields, select Help > Mail Merge Fields from the TaiRox Mail Merge menu. 
The program will display a list of mail merge fields along with the corresponding mail merge format that 
you can copy and paste into your mail merge templates. 

 

Mail Merge contains field names with extended descriptions to make it easier to create mail merge 
templates. For example, the following Accounts Payable fields will appear if you select “Mail Merge 
Fields” from the Mail Merge menu in the TaiRox Productivity Tool > Accounts Payable Tools folder. 
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Using Microsoft Word to create a merge template 

You use Microsoft Word to create merge template documents. 

To add merge fields to a document in MS Word: 

• Open the merge document. 

• Position the cursor where you want to insert a merge field and choose Insert > Quick Parts > 
Field or Insert > Field (if that choice is available) or choose Insert > Field. Note that your 
version of Office may be slightly different than shown below. 

 

• Choose “MergeField” as the type of field that you are inserting, and then specify the merge field 
name that you are inserting.  

 

You can copy the name directly from the list in the mail merge help by double-clicking the field 

name, and pressing CTRL+C. 

 

File Format for an Importing Mail Merge Lists 

Mail Merge lets you import lists of recipients. Note that the list type will depend on where you are running 
Mail Merge. 

For example, you will import a list of customer numbers if you run Mail Merge from the Accounts 
Receivable Productivity Tools folder. 
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Customer List 

The Excel Spreadsheet customer list for Mail Merge is a single column with “IDCUST” as the column 
heading in the first row.  

 

Notes: 

• All other columns are ignored. This means that you can add descriptions and notes to your 
spreadsheet without affecting the file import. 

Vendor List 

The Excel Spreadsheet vendor list for Mail Merge is a single column with “VENDORID” as the column 

heading in the first row.  

 

Employee List 

The Excel Spreadsheet employee list for Mail Merge is a single column with “EMPLOYEE” as the column 

heading in the first row.  

 

Item List 

The Excel Spreadsheet item list for Mail Merge is a single column with “ITEMNO” as the column heading 

in the first row.  
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