Check Mailing Labels Running Check Mailing Labels

Check Mailing Labels

Check Mailing Labels integrates Sage 300 with Microsoft Word’s Mail Merge function. The integration
presents a Sage 300 style interface from within the Sage 300 desktop.

Check Mailing Labels lets you print addresses for checks on envelopes or mailing labels. This lets you
print addresses on envelopes with A/P checks rather than use a window envelope. In other words, the
program is designed for added check security.

The program is integrated with the A/P vendor check batch table, eliminating the need to export data from
Sage 300, manually manipulate A/P data, and define the resulting file as a Microsoft Word “data source”.

All A/P check merge data fields are displayed in the program with field definitions to make it easy to
prepare a Check Mailing Labels template file in Microsoft Word.

Once you have created the Check Mailing Labels merge document, you can select checks by ranges of
batch numbers, vendor numbers, payment codes, vendor currency codes, bank currency codes, account
sets or payment dates, then “cherry-pick” the results for printing Check Mailing Labels.

Check Mailing Labels lets you:
e Print check mailing labels or envelopes for selected checks directly from the Sage 300 desktop.

e Specify a number of print options for the merge documents, such as data formatting and blank
line suppression.

e Select checks by specifying ranges of batch numbers, vendor numbers, payment codes, vendor
currency codes, bank currency codes, account sets or payment dates.

e Specify the list of checks by importing an Excel spreadsheet list.
e Specify additional criteria for check selection.
e “Cherry-pick” records for printing labels/envelopes from the selected set of checks.

e Click the Mail Merge button to complete the document merge operation for all included records in
one step.

e View a log of all document merges after processing.

Running Check Mailing Labels

The Check Mailing Labels icon appears in the Accounts Payable folder for TaiRox Productivity Tools
on the Sage 300 desktop.

» TaiRox CRM and Collections @ -
= T s R Tt Accounts Payable Tools (Check Mailing Labels)

Accounts Payable Tools Licensed to: Don Thomson, TAIROX SOFTWARE INC
Accounts Receivable Tools Dealer: TaiRox Software, Inc
e Den

Administrative Services Tools
General Ledger Toals
Inventory Control Tools @ @ @ = — 1=t
Multi-Company Tools H == M
Extended Vendars. Vendor Inquiry Extended Remit-To Mail Merge Ext. A/P Create Check Mailing Labels
Locatiens Payment Batch

Order Entry Tools

Payroll Tools

SQSG For Help, press F1 Session Date: 2024-04-08
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Check Mailing Labels Running Check Mailing Labels

Choose the merge document template and output document for the merge

Users must first select a Check Mailing Labels template (MS Word document) and an MS Word output
document.

In the following example, I've chosen the default template document in the Sage 300 program folder:
Sage300\XL61A\Documentation\APCK.doc, and my merge output document is on the Windows desktop
— for convenience.

Template |F:\Sage'\Sag93DD\XLE‘I ArDocumentation\APCK doc | Browse
Document |C:‘\Users\dorrt‘\Deslﬂop\‘u’endor[hedcs.docx | Browse
Check Mailing Labels Load

Note: If you click the “Load” button without specifying any check ranges under “Select Checks By”, the
program will load all printed checks from posted check batches — even ones for which you have already
printed labels or envelopes.

You must select the range of checks for printing labels before you click the Load button.

Selecting checks

Choose data ranges for creating merge documents:

Check Range
Select Checks By From To

Batch Number [~] 4 q | 46 Q)
MNane

Vendor Number
Payment Code
Wendor Curency Code
Bank Currency Code
Account Set

Payment Date
i‘l%onel

| {MNone) - |

e You can use up to seven fields to select checks -- check batch numbers, vendor numbers,
payment codes, vendor currency codes, bank currency codes, account sets or payment dates.

e The program selects checks that have been printed and that have an assigned check number.

For instructions on importing a list of Checks using the File > Import menu choice, see Importing a
List of Check Recipients and File Format for an Import Check List.

Choose additional criteria:

I Additional Criteria... I

Column | Fiscal Period

Field Fiscal Period
Criteria
Cr
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Check Mailing Labels Importing a List of Checks

¢ Click the Additional Criteria button to further restrict the records retrieved for printing Check
Mailing Labels. In the above example, we’ll print checks for period 6.

e Click the Save button to save the additional criteria.

Load the list of selected records and choose which ones to use:

e Click the Load button to display the selected list of checks.

Template |F:\Sage\SageBDﬂ\XLG'lA\Documerrtaﬁon\}\F'C K.doc | Browse
Document |C:\User5\dont\Desktop\Vendor[}'|ed(5 docx | Browse
Chechk Mailing Labels Load
Check Range
Select Checks By From
| ]| Q
| {Mone) V |
| (None) i |
| {Mone) V |
| (None) hd |
| {Mone) V |
| (Mone) v |
Additional Criteria...

Include | [B Batch Number | Ertry Number | Vendor Number | Check Number Payment Amount | Cumency | Vendor |
Yes 46 2 1450 000000000001200003 63066 CAD Interco

o Go back and adjust the ranges or additional criteria if necessary.

Remember that the program loads records for all printed checks that match the criteria you
specify.

Importing a List of Checks

Important: If you are importing a list of checks, you must first select a Check Mailing Labels template
(MS Word document) and an output document. See Choose a merge template and output document.

e Choose File > Import from the Check Mailing Labels menu.

Customize... ge 300" XL61A\Documentation \APCK doc | Browse
ont'Desktop'\VendorChecks docx | Browse

Import..

Close Load

e Select the list of checks that you want to process.

™ < Sage » 5age300 » XL61A » Documentation » v | D £ Search Documentation

Organize » MNew folder =~ [@ e
SGT1A ~  Name Date modified Type
sharedData ENG 2024-04-02 11:55AM  File folder
SITA B3] BillsOfMaterial xlsx 2022-08-13 5:49 PM Microsoft Excel W...
SPT1A @ Checks.xlsx 2024-04-03 %12 AM Microsoft Excel W...
SRT1A @ Customers.xlsxc 2022-09-13 5:49 PM Microsoft Excel W...
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Check Mailing Labels Choosing Checks from the Grid

e The program will import the list and load all valid checks that match the criteria (printed checks
with check numbers) into the grid — setting all checks to “Include” — and display a message
stating the number of checks that were successfully loaded. It also lists any checks that could not
be imported.

Include | [ Batch Number | Ertry Number | Vendor Number | Check Number Payment Amount | Cumency | Viendor |
Yes 46 2 1450 000000000001200003 63066 CAD Intercol

Message

Description: 1 Payments/Adjustments imported from 'F-\Sage
“Sage3000%L61ANDocumentation \Chechks xlax’.

e The import check list that you specify must provide the batch numbers and entry numbers for
each check that you want to load (as below).

File Home Insert Page Layout Formulas Data Review View At
Al e fe | CNTBTCH

A B ¢ |, D | E | F | 6
1 |CNTBTCH ICNTENTR
2 |46 2

Choosing Checks from the Grid

e Use the Select All and Select None buttons below the grid to set all records to Yes for Include or
No to exclude.

Select Al Select None

e Double-click in the Include column to “cherry-pick” checks:

Include | [ Batch Mumber | Ertry Mumber | Vendor Number | Check Mumber | Payment Amourt | Cumency | Vendor / Payse N

8.264.61 USD Chloride Systems

_ nnnnnnnnnnn 3332123 Intercontinental Bl

Yes k 57 3 15DD 151,456.63 USD Gould Manufactu
Yes 57 4 1580 ﬂDDDDDDDDDD 1.12364150 USD Grant Office: Suppl

e Click the Batch Number column to drill down on the selected payment entry to confirm the details:

826461 USD Chloride Systems

_ Dnnnnnnnnnn 33.321.23 | USD Intercontinental El

Yes 57 3 ‘IEDD 15145663 USD Gould Manufactu

Click the Mail Merge button to run the Check Mailing Labels:

The program generates the merge file and then asks if you want to open Microsoft word to print the
merge document (i.e. the labels/envelopes).

ChUsers\dont\Desktop'VendorChecks.docx has been created.

o Do you want to open Microsoft Word to print the document.

Yes Mo

If the target document does not exist, the message will include that information and create it for you
when you proceed.
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Check Mailing Labels Additional Check Mailing Labels settings

Additional Check Mailing Labels settings

To display additional settings for Check Mailing Labels, select File > Settings from the Check Mailing
Labels menu.

File
Customize... age 300 XLE61 A \Documentation \ APCK doc | Browse
ont*Desktop'VendorChecks docx | Browse
Import..
Close Load
Settings... From To
Reset Defaults ™ | | 5-"‘I| _\ | 57 \
] {Monej W

The settings form appears as follows:

Format Field Values

[] Perform Mail Merge with Waord Maximized
[] Highlight Merge Fields

[ Suppress Blank Lines

[] Pause Mail Merge on Emor

Format Field Values: This setting determines whether or not to use the field presentation information
defined for the Sage 300 field, or whether to use the raw data value.

For example, field APTCR_SWRATETC (vendor rate overridden) has 2 presentation values, No and Yes,
which represent the raw integer values of 0 and 1.

If you select this setting, the program will insert a merge value of “No” or “Yes”; if you do not select it, the
program will insert a “0” or “1” into your document.

Perform Mail Merge with Word Maximized: This setting determines whether Microsoft Word is run in
the background or it is launched in the foreground (letting you view the Check Mailing Labels operation).

Highlight Merge Fields: You can use this setting to help proof your merged documents.
Suppress Blank Lines: By default, Microsoft Word suppresses blank lines in address labels when the
result of a MERGEFIELD is blank. You can use this setting to determine whether to suppress blank lines

or not.

Pause Mail Merge on Error: You can use this setting to pause the create labels process and display a
troubleshooting error if you encounter problems while running the program.

Creating Merge Templates for Check Mailing Labels

Sample Address Labels templates in \Sage300\XLxxx\Documentation

TaiRox Productivity Tools includes sample labels documents which contain commonly used merge fields.
You can use these documents as a starting point for creating your own templates.

TaiRox Productivity Tools for Sage 300 5
© 2009-2025 TaiRox Software Inc. All rights reserved.



Check Mailing Labels Creating Merge Templates for Check Mailing Labels

APCK.Doc: Includes the following fields -- <kxAPTCR_IDVEND», «APTCR_NAMERMIT>,
«APTCR_TEXTSTRE1», «<APTCR_TEXTSTRE2», «<APTCR_TEXTSTRE3», «<xAPTCR_TEXTSTRE3»,
«APTCR_TEXTSTRE4», <APTCR_NAMECITY», «xAPTCR_CODESTTE» and «<APTCR_CODEPSTL».

Displaying available merge fields

To access a complete list of Check Mailing Labels fields, select Help from the Check Mailing Labels
application menu in Sage 300, and then select “Mail Merge Fields”.

The program will display a list of Check Mailing Labels fields along with the corresponding Check Mailing
Labels format that you can copy and paste into your Check Mailing Labels template.

Help

Templ User Guide Jocumentation \APCK doc | Browse
Docun Mail Merge Fields... ndorChecks docx | Browse
Check License Information... Load
Checl

TaiRox Home Page
Select From To

About... ~ =
Batc 2 B 5Q | 57 Q

The list of field names with extended descriptions make it easier to create Check Mailing Labels
templates.

Check Mailing Labels

Name Description Format
APTCR_BTCHTYPE Batch Type \* MERGEFORMAT
APTCR_CNTBTCH Batch Number \* MERGEFORMAT
APTCR_CNTENTR Ertry Number \* MERGEFORMAT
APTCR_IDRMIT Check Number \* MERGEFORMAT
APTCR_IDVEND Wendor Number \" MERGEFORMAT
APTCR_DATERMIT Payment Date/Adjustment Date \* MERGEFORMAT
APTCR_TEXTRMIT Ertry Description \* MERGEFORMAT
APTCR_NAMERMIT Wendor / Payee Name \" MERGEFORMAT
APTCR_AMTRMIT Check Amourt in Bank Cum. \#0.00
APTCR_AMTRMITTC Check Amount in Vendor Curr. \# 0.00
APTCR_RATEEXCHTC Wendor Exchange Rate \* MERGEFORMAT
APTCR_SWRATETC Wendor Rate Ovemidden \* MERGEFORMAT

List Presentation with 2 items in the list

0-Ne

1-Yes w

Close

Using Microsoft Word to create a merge template
You use Microsoft Word to create merge template documents.

To add merge fields to a document in MS Word:

e Open the merge document.

e Position the cursor where you want to insert a merge field and choose Insert > Field or choose
Insert > Quick Parts > Field or Insert > Field (either choice may be available). Note that your
version of Office may be slightly different than shown below.

File ome B Desion  Layout  References eview View Help Acobat 2 Tell me what you w 3 share
er Page = —T T SmartAr - [ | |I=] QuickParts > [ Signature Line - — y
BlankPage L[4 ictur AutoText + ol -
Table > Comment " Text = Field | Bookmark
= Page Break . [ZShapes~ - 5 Cross-reference [ Page Mumber - Box -
Pages Tables sustrtions Addbins. Media Links Comments  Header & Footer I— Field, N |ncl; sields || Bookmarts.

1 Building Blocks Organizer
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Check Mailing Labels File Format for an Import Check List

e Choose “MergeField” as the type of field that you are inserting, and then specify the merge field
name that you are inserting.

Field 7 x

Please choose  field Field properties. Freld options
Categones: Field name; [[]7ext 10 be inserted before:
ey ~ icmem pesd |
Text o be inserted g
Held names: Format H
Greetingtine ~ lwore ] e
Hyperink Uppercase [ o
0 Lowercase
Inchudepicture First capital [ vertical formating
IndudeText Tile case
Index
el
Kepwords
Lastsaveasy
Link
st
htergeseq
et
ortt
WoteRef -

[4] Preserye formatting durmg updates
Descriphion:
msert 3 mail merge field

prepere ==

You can copy the name directly from the list in the Check Mailing Labels help by double-clicking
the field name, and pressing CTRL+C.

Check Mailing Labels

Name Description Format &
APTCR_BTCHTYPE Batch Type \* MERGEFORMAT
APTCR_CNTBTCH Batch Number \* MERGEFORMAT
APTCR_CNTENTR Erttry Number \* MERGEFORMAT
APTCR_IDRMIT Check Number \* MERGEFORMAT
ABTCE IOVEND Wendor Number \* MERGEFORMAT

Paymert Date/Adiustment Date \* MERGEFORMAT
TETCR. TEXTEN Er I \* MERGEFORMAT
APTCR_NAMERMIT Vendor / Payee Name \* MERGEFORMAT
APTCR_AMTRMIT Check Amount in Bank Cur. \#.0.00
APTCR_AMTRMITTC Check Amount in Vendor Curr. \# .0.00
APTCR_RATEEXCHTC Vendor Exchange Rate \* MERGEFORMAT
APTCR_SWRATETC Vendor Rate Ovenidden \* MERGEFORMAT

List Presentation with 2 items in the list:

0-No

1-Yes v
Close

File Format for an Import Check List

Check Mailing Labels lets you import lists of checks for printing labels instead of using the range fields to
select checks.

The Excel Spreadsheet for specifying checks has two columns for listing the check batch number and
entry number for each check for which you want to print labels or envelopes. The first row must have the
column headings CNTBTCH and CNTENTR.

A B C
1 |CNTBTCH lcnTenTR
2 (a6 2

Note: All other columns are ignored. This means that you can add descriptions and notes to your
spreadsheet without affecting the file import.
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