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Extended PO Receipt Entry 

Extended PO Receipt Entry is an enhanced replacement for the Sage P/O Receipt Entry form. It provides 

you with more information while entering a receipt and fast access to additional PO, Vendor, and Item 
information. 

The following pictures show some of the extra features on the Extended PO Receipt Entry screen: 

Sage P/O Receipt Entry screen TaiRox Extended PO Receipt Entry screen 

 
 

Click the following links for details on each Extended PO Receipt Entry feature: 

SmartFinder – Receipts Finds purchase orders and shows PO details quickly for any vendor. 
SmartFinder – Vendors Find a vendor quickly from a name, description, phone number or an 
address. 
SmartFinder – Purchase Orders Finds purchase orders and shows PO details quickly for any vendor. 
SmartFinder – Items Find an item quickly from partial item number or description. Search also by 
manufacturer’s item number with the Enterprise version of Productivity Tools. 

SmartFinders provide fast, browser-like search capabilities for looking up data on the PO Receipt 
Entry screen.  They search more fields than the Finder, and search in all text fields at once. For 
example, search for “Seattle” if you think that the vendor or contact is in Seattle. 

Vendor Inquiry (button left of the vendor name field) provides complete vendor data, including POs, 

receipts, purchases, requisitions, invoices, payments, adjustments, etc. 
Vendor Optional Fields Display any vendor optional fields on the Extended PO Receipt Entry screen. 
Require PO Number Optionally require purchase order numbers on receipts for all or selected 
vendors. 
Display and Edit Optional Fields Inline in the PO Receipt Entry Grid Optional fields appear as grid 
columns. 
Link PO Receipt Lines to the Original OE Order Lines Use an optional field to link to order lines. 
Quantities Display Show item quantities at the bottom of the standard PO entry window - the same 
item quantities that are displayed in the Sage 300 Order Entry module. 
Item Quantities at Other Locations Display quantities available at other locations or in other 
companies while entering a purchase order. 
Drop Ship Drop ship dozens of purchase order detail lines in a single operation. 
Receive in Sorted Order (Receive button) Receive items by item Number or several other selectable 
orders.  
Quick PJC Entry Default newly inserted lines to have the same Contract, Project and Category 
selections as the previously entered line.  
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SmartFinder – Receipts 

Click the Receipt Number button at the top of the screen to open the SmartFinder.  

• Enter one or more words or word fragments in the entry field to search multiple tables and fields, 
and then click the Find button.  

• Search returns records which contain the search string in any of the searched fields. 

Note: 

o All of the word fragments must be present in one of the fields being searched. (For example, 
if you searched for “Ross Blvd”, you will not see an invoice where “Ross” is in the Vendor 
Name field and “Blvd” is in the Address 1 field.) 

o Addresses (e.g. the vendor address) are treated as a single field. 

Display:  

• The top grid displays the receipts matching the search criteria. Double-click to select an receipt. 

• The bottom grid displays the item details of the receipt highlighted in the top grid. 

• Click the Address 1 column heading or double-click the address to launch Google Maps with the 
vendor address. You can also check the locations of Ship-To and Bill-To addresses. 

• Double-click email addresses (such as the Contact E-mail) to create new emails. 

 

Selection:  

• Double-click a receipt in the top grid to select the receipt and display the receipt details on the 
screen. 
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SmartFinder – Vendors 

Click the Vendor Number button to open the SmartFinder for searching vendors.    

Search:  

• Enter one or more words or word fragments in the entry field to search multiple tables and fields.  

• You can also filter for Active vendors. 

• Search returns vendors and remit-to location records which contain the search string in any of the 
searched fields – for example, one record may have “Royal” in the name, where another may 
have it in the address field. Both records will be displayed. 

Note: 

o All of the word fragments must be present in one of the fields being searched. (For example, 

if you searched for “Ross Blvd”, you will not see a vendor where “Ross” is in the Vendor 
Name field and “Blvd” is in the Address 1 field.) 

o Addresses (e.g. the vendor address) are treated as a single field. 

Display:  

• The top grid displays the vendors matching the search criteria.  

• The bottom grid displays the remit-to locations that match the search criteria.  

Note that the remit-to locations may not be related to the vendor records displayed in the top part 

of the screen. The screen below displays remit-to locations for two different vendors. 

• Click the Address 1 column heading or double-click the address to launch Google Maps with the 
vendor address. You can also check the locations of Ship-To and Bill-To addresses. 

• Double-click email addresses (such as the Contact E-mail) to create new emails. 

 

Selection:  

• Double-click a vendor in the top grid to select and enter the vendor on the receipt. 

• Double-click a remit-to location in the bottom grid to add the vendor and this remit-to address to 
the receipt. 
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SmartFinder – Purchase Orders 

Click the PO Number button to open the SmartFinder for searching purchase orders.    

Search:  

• Enter one or more words or word fragments in the entry field to search multiple tables and fields, 
and click the Find button. (Note that you must entry a criterion – such as “a” – to search.) 

• You can filter by purchase order type and include completed and on-hold purchase orders. 

• Search returns records which contain the search string in any of the searched fields – for 
example, one record may have “Royal” in the name, where another may have it in the address 
field. Both will be displayed. 

Note: 

o All of the word fragments must be present in one of the fields being searched. (For example, 

if you searched for “Ross Blvd”, you will not see a PO where “Ross” is in the Vendor Name 
field and “Blvd” is in the Address 1 field.) 

o Addresses (e.g. the vendor address) are treated as a single field. 

Display:  

• The top grid displays the POs for the vendor that match the search criteria. Double-click to select 
a PO.  

• The bottom grid displays the details of the purchase order highlighted in the top grid. 

• Click the Address 1 column heading or double-click the address to launch Google Maps with the 
vendor address. You can also check the locations of Ship-To and Bill-To addresses. 

• Double-click email addresses (such as the Contact E-mail) to create new emails. 
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SmartFinder – Items 

Click the Item Finder button under the item grid to open the SmartFinder for items. 

 

 

The Item Finder provides several item search options and displays search results in a selection grid with 
columns such as description, alternate item number, stock item flag, or sellable flag. You can select which 
columns are displayed and searched. 

 

• The Item Finder appears with the “Search” selected by default on the Items tab. This is the most 
common way to look up items. 

o Type a partial item description or item number in the text field, optionally select Active Items 
Only, and press Enter to immediately search for items. 

• Alternatively, select a different “Find Items By” choice from the Find Items By dropdown. For 
example, you can choose “Show All Records” and specify a range of item numbers, structure 
codes, categories, or account sets using the range fields. You can specify more selection fields 
using Additional Criteria. 

 

Notes: 

• The above search screen displays two tabs for looking up inventory items – Items and 
Manufacturer’s Item Number – which let you search for I/C item numbers or for manufacturer’s 
item numbers. 

Search for manufacturer’s item numbers is a Productivity Tools Enterprise feature.  

The Manufacturer’s Item Number tab will not appear unless you have a license for the Enterprise 

version of Productivity Tools. 



Extended PO Receipt Entry SmartFinder – Items 

TaiRox Productivity Tools for Sage 300  6 

© 2009-2025 TaiRox Software Inc. All rights reserved.  

• If you do not select the SmartFinder “Search” option, you can select up to four item field ranges – 
by item number, status, structure code, category code, and account set code. 

• The item price is the quantity zero price for that customer. 

• The Item Finder also displays all columns that are in the standard Sage Finder. You can choose 
which columns appear in the Item Finder by selecting File > Settings from the Item Finder menu. 

• Selecting an item inserts a new row into the PO entry grid.  

Searching for Inventory Control Item Numbers on the Items Tab 

The Item Finder on the Items tab provides 7 search options: 

 

• Search (most common option) – to search for words or word fragments in item text fields (such 
as the item number, item description, structure code, category, price list, picking sequence, and 
comments). This search works like the PO Number and Vendor Number SmartFinders. 

• Show All Records – to select items from all item records based on ranges of Item Number, 
Structure Code, Category, and Account Set Code and on item Status. You can also specify 
additional selection criteria to use more item fields. 

• Item Number – to select items using part of the item number. You can refine your selection 
based on ranges of Item Number, Structure Code, Category, and Account Set Code, select items 
by item status, and specify additional selection criteria using more item fields. 

 

Search by Item Number, Description, Structure Code, Category and Account Set Code also let 
you specify a search value that the item starts with or contains.  

Note that the “Search” choice automatically looks all displayed fields.  

• Description – to select items that begin with or contain a string of characters. You can refine 
your selection based on ranges of Item Number, Structure Code, Category, and Account Set 
Code, select items by item status, and specify additional selection criteria using more item fields. 

• Structure Code – to select items with structure codes that begin with or contain a string of 
characters. You can refine your selection based on ranges of Item Number, Structure Code, 
Category, and Account Set Code, select items by item status, and specify additional selection 
criteria using more item fields. 

• Category – to select items in categories that begin with or contain a string of characters. You can 
refine your selection based on ranges of Item Number, Structure Code, Category, and Account 
Set Code, select items by status, and specify additional selection criteria using more item fields. 

• Account Set Code – to select items with codes that begin with or contain a string of characters. 
You can refine your selection based on ranges of Item Number, Structure Code, Category, and 
Account Set Code, select items by item status, and specify additional selection criteria using 
more item fields. 
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More on the “Search” option (most common option):  

 

• Select Find Items by Search. (Note that Find Items By defaults to the last choice used.) 

• Enter one or more words or word fragments in the next field to search multiple item tables and 
fields. (Note that the program scans all columns displayed by the Item Finder.) 

• You can filter for Active items only. 

• Search returns items and vendor item numbers that contain the search string in any of the 
searched fields – for example, one record may have “Desk” in the Description field, where 
another may have it in the Comment 1 field. Both items will be displayed. 

o Using multiple words in the search? Enter "300 Main" and the search will find entries "300 
Main Street" as well as "123 Main Street, Suite 300".  

o Searching for a phone number? Enter the phone number segments separated by blanks. 
Enter "451 8991" and the search will find "(451) 555-8991" as well as "(408) 451-8991". 

Note: 

o If using the Search option, all of the word fragments must be present in one of the fields that 

are displayed on the screen. (For example, if you search for “desk lamp”, you will not see an 
item where only “desk” is in the Description field and only “lamp” is in the Comment 1 field.) 

Display:  

• The top grid displays the items matching the search criteria. The screen below shows “Desk 
Lamp” in the description of one item, and “Desk Lamp” in the comments of the second one – so 
both appeared. 

• The bottom grid displays any entered vendor item numbers for the item selected in the top grid.  

 

Selection:  

• Double-click an item in the top grid to select and enter the vendor on the purchase order. 

• Double-click a vendor item number to enter the item number and the vendor item number into the 
PO form. 
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Selecting columns to display – and scan – in the Item Finder  

Choose File > Settings in the Item Finder window to change column settings.  

 

• The current columns that are displayed appear in the right-hand column.  

• Highlight columns that you want to add in the left-hand column and click the Include button. 

Note: 

• Settings apply to the currently selected tab. For example, if you want to change the columns 
on the Manufacturer’s Item Number tab, choose the tab first, and then select File > Settings. 

• Only the “Included Fields” are used for searching. For example, if you do not include the 
Comments 1 field, the program will not scan the comments. Also note, that the number of fields 
will affect performance. If search is slow, remove columns that you don’t need. 

All of the possible columns are shown below. Note that optional and calculated fields are also available 
for inclusion – for example Item’s Color and Qty. Available for Sale. 
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Searching for Items on the Manufacturer’s Item Numbers Tab 

Note:  The Manufacturer’s Item Number tab will not appear unless you have a license for the Enterprise 
version of Productivity Tools. 

Search for manufacturer’s item numbers is a Productivity Tools Enterprise feature. 

 

• The Manufacturer’s Item Number Finder appears with “Search” selected by default. This is the 
most common way to look up items by manufacturer’s item numbers. 

o Type a partial item description or item number in the text field, optionally select Active Items 

Only, and press Enter to immediately search for manufacturer’s item numbers. 

• Alternatively, select “Manufacturer’s Item Number” or “Manufacturer’s Item Description” for 
searching. 

The Item Finder on the Manufacturer’s Item Number tab provides 3 search options: 

• Search (most common option) – to search for words or word fragments in manufacturer’s item 
text fields (the manufacturer’s item number or the manufacturer’s item description).  

This search works like the PO Number and Vendor Number SmartFinders. 

• Manufacturer’s Item Number – to select items using part of the manufacturer’s item number.  

  

You can specify that the item number starts with or contains the string that you enter. 

• Manufacturer’s Item Description – to select items using part of the manufacturer’s item 
description. As with the item number, you can specify that the item description starts with or 
contains the string that you enter. 

Note that the “Search” choice automatically looks in the manufacturer’s item number and the 

manufacturer’s item description fields.  
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Vendor Inquiry 

Vendor Inquiry button displays the TaiRox Productivity Tools Vendor Inquiry screen – a convenient way to 
view data related to the vendor. Each tab focuses on an aspect of the vendor’s data.  

You can also look up details for other vendors while you are on this screen. 
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Vendor Optional Fields 

If you use the Sage 300 Optional Fields module, you can display any optional fields from the A/P vendor 
record on the right side of the Extended PO Receipt Entry screen. 

 

This feature lets you view notes concerning the account during data entry, and also view receipt 
requirements – in this example, one of the fields is “Require PO Number on Receipts.” 

You specify which optional fields to display on the Extended PO Receipt Entry screen using the 
Productivity Tools Options program. 

Setting Up Optional Fields on the Extended PO Receipt Entry Screen 

You choose the vendor optional fields to display on the Extended PO Entry screen, Extended PO Receipt 
Entry screen and Extended PO Invoice Entry screen using the Productivity Tools Options program on the 
Sage 300 Desktop – as shown at the bottom of the following example.  

 

Require Purchase Order Number on Receipts 

Extended PO Receipt Entry includes an option to require users to include purchase order numbers on 

receipts for all or for selected vendors. You select this option in the Productivity Tools Options program. 
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If you use the option to force PO numbers on receipts, but try to post a receipt that’s missing the PO 
number, the following message appears. 

 

Notes: 

• The program lets you require PO numbers for all vendor receipts or only for vendors with a “Yes” 
value for a specific optional field. For example, the Extended PO Receipt Entry screen pictured 
above shows an optional field called “Requires PO Number on Receipts” – where the value “Yes” 
for the field determines that a PO number is required. 

• If a vendor record does not include a value for the Yes/No optional field, the program will not 
require a purchase order number when you create a receipt.  

Setting Up the Option to Require PO Numbers on Receipts 

In the following example, the program uses the Yes/No value in Optional Field “REQPONUM” (with a 
description “Requires PO Number on Receipts”) to determine whether vendors require a PO number. 

• You choose the option and the optional field using the Productivity Tools Options program on the 
Sage 300 Desktop: 

  

• If you use the option to force PO numbers on receipts – and the vendor record includes the 
control field with a “Yes” value – the following message appears when you try to post a receipt 
that’s missing the PO number. 

 

• In this example, the “Requires PO Number . . .” field also appears at the top of the Optional Field 
list on the Extended PO Receipt Entry screen It was added to the set of optional fields that are 
displayed in Extended PO Receipt Entry using the Productivity Tools Options program. 
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Display and Edit Optional Fields Inline in the Receipt Entry Grid 

If you have the Enterprise version of TaiRox Productivity Tools, you can display and edit optional fields for 
order details inline in the Extended PO Receipt Entry detail grid. 

 

You select the option to display optional fields inline in the Productivity Tools Options program – available 

in the TaiRox Productivity Tools folder on the Sage 300 Desktop. 

Adding Detail Optional Fields to the PO Receipt Entry Details Grid 

• Select the Productivity Tools Options program. Note that you must be using TaiRox Productivity 
Tools’ Enterprise Edition to add optional field columns to the grid. 

• Choose the Purchase Orders tab and then select the extended transaction entry programs where 
you want to display optional fields.  

You can add optional fields to the detail grids in Extended PO Entry, Extended PO Receipt Entry, 

Extended PO Invoice Entry, and to the Receipt Additional Cost and Invoice Additional Cost entry 
grids. 

 

Link PO Receipt Lines to the Original OE Order Lines 

Extended PO Receipt Entry also lets you link PO lines created from an O/E order to the original order 
lines. 

To link PO lines created from an O/E order to the original order lines 

• Create a new integer optional field in Common Services and give it an appropriate name – in this 
example, “ORDERLINENUM”. 
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• Add the integer optional field to purchase order details using the Optional Fields program in the 
P/O Setup folder. Do not set a value for the field, make it required, or auto-insert it on detail lines. 

 

To have the order line numbers follow through to the receipt, invoice, CR/DR notes and returns, 
you must also add it to the receipt details, invoice detals, return details, and cred/debit details. 

• When you create a PO in Order Entry from order details, make sure that you use the “Create 
Purchase Order” button in Extended Order Entry (not the “Create PO” button). 

 

Quantities Displayed on the PO Receipt Entry screen 

Extended PO Receipt Entry displays item quantities for the selected location and item at the bottom of the 
PO Receipt Entry window – like the quantities displayed on the Extended PO Entry screen. 

The program also provides drill-down links for quantities on sales order, quantities on purchase order, 
and committed quantities.  

Note that the screen below shows the single location displayed for the current line item in the grid, as well 
as a total for all locations.  
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Displaying Quantities for multiple locations and companies 

Extended PO Receipt Entry can also display item quantities available at other locations – either at the 
bottom of the Extended PO Receipt Entry screen or in a separate window.  

To display quantities for multiple locations and companies: 

• Select the Extended PO Receipt Entry > File > Settings menu choice to change the Item 
Quantities display settings. 

  

o Do Not Display – shows only total quantities and quantities for the current line item location. 

 

o Display on Entry Screen – adds a new grid to the bottom of the screen that displays 
quantities at all locations, in the current company and any associated companies. 

 

o Display on Separate Screen – displays the item quantities at all locations in a separate 

window. (The image below shows the window widened to display most of the quantity 
columns.) 

 

Click the All Locations button to move the Quantities in front of other windows (if hidden).  

 

The All Locations button appears at the bottom of the Extended PO Receipt Entry screen if 
you choose to dsplay quantities on a separate screen. 

Item Quantities will be refreshed as you move to other detail lines.  

Selecting which companies and locations are displayed 

An administrator must first set up the Sage 300 company databases and locations that are displayed in 

the Item Quantities grid. 

• Go to TaiRox Productivity Tools > Options, and click the Item Quantities tab. 
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o Use the Insert and Delete keys to add or remove locations and companies from the Item 
Quantities grid and to change the order that locations appear. 

Each user can customize the item quantities grid by hiding and moving columns to suit their own needs. 

For example: 

• You can hide the Database ID and Name columns if all locations are in the same Sage 300 
company.  

• You can also hide the Item Description and Stocking Unit if these are the same at all locations. 
Hide and re-arrange columns by dragging and dropping. 

 

Using the Extended Drop Ship window 

The Extended Receipt Entry Drop Ship window lets you set the drop-ship column for multiple receipt 

detail lines at once to “Yes” and assign them all the same drop ship address, rather than double-clicking 
the column and assigning addresses one at a time using the Drop Ship column heading zoom button. 
(This functionality is used more in Extended PO Entry when creating purchase orders.) 

To set the drop ship column to “Yes” and set the address for multiple items: 

• Click the Drop Ship button to display the Drop Ship form.  

• The top portion of the form is the same as the standard Drop Ship form.  

• The grid at the bottom displays the Purchase detail lines.  

Choose the first drop ship address and items 

• Pick a shipment address from the dropdown list at the top of the screen. 

 

• Double-click the Include column (select “Yes”) for each item that you want to drop ship to the 
selected address. 
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• Click the Drop Ship button at the bottom of the form to update items in the PO Receipt Entry 
window grid as drop-shipped items with the selected address. 

Choose the second drop ship address and items 

• Select another shipment address to drop ship other items on the receipt to a different location. 

• Double-click the Include column (select “Yes”) for each item that you want to drop ship to the new 
address. 

• Click the Drop Ship button on the form to update the PO Receipt Entry grid with the selected 
address. 

• Press Cancel when done to return to the main PO Receipt Entry window. 

Receive in Sorted Order 

Receive in Sorted Order functionality is most useful when a large PO is being received and the packing 

slip is not sorted by PO line number.  

• Press the Receive button to pop up a window to display items sorted in a different order.  

• You can specify three levels of sort order. Sort order choices are by Line Number, Item Number, 
Vendor Item Number, Item Description, Quantity Received, Received to Date, and Quantity 
Outstanding. 

• Received items can be entered on this form using a time-saving “enter-tab-enter-tab-…” 
sequence.  

 



Extended PO Receipt Entry Quick PJC Entry 

TaiRox Productivity Tools for Sage 300  18 

© 2009-2025 TaiRox Software Inc. All rights reserved.  

Quick PJC Entry 

To speed up data entry, Extended PO Receipt Entry will default inserted lines to the previous entry's 
selections for Contract, Project and Category when multiple lines use the same selections.  

The following form shows how the order form appears immediately after pressing the Insert key to create 
the second line (with default values for the Contract, Project, Category and Cost Class fields): 
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